Привет, незнакомец!

Похоже, вы здесь новенький. Чтобы принять участие, нажмите одну из кнопок ниже!

CISCO 1921/K9 PPTP до провайдера

отредактировано июня 2016 Раздел: VPN
Добрый день!
Помогите горе админу

Провайдер дает подключение по PPTP. Как его настроить если нет команд которые нужны. Вопрос.

sh ver
Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9_NPE-M), Version 15.3(3)M6, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Tue 04-Aug-15 03:33 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)

Router uptime is 3 hours, 8 minutes
System returned to ROM by reload at 04:28:49 UTC Tue Jun 7 2016
System image file is "usbflash0:c1900-universalk9_npe-mz.SPA.153-3.M6.bin"
Last reload type: Normal Reload
Last reload reason: Reload Command


Может быть у меня кривая прошивка какая-то,

я делаю так.

vpdn enable

vpdn-group 4

request-dialin

Затем должна быть команда protocol pptp и initiate-to ip A.B.C.D

Но у меня нет в выборе pptp, а только l2tp и все.



что делать не поможете.
Тэги темы:

Комментарии

  • Держи мою шпаргалку по ppp, может пригодиться http://file.sampo.ru/ntnsrn/
  • Вот спасибо!!! Пригодится я надеюсь.
  • А может быть дело в прошивке, в самой версии
  • mitushinem написал:

    Добрый день!

    я делаю так.

    vpdn enable

    vpdn-group 4

    request-dialin

    Затем должна быть команда protocol pptp и initiate-to ip A.B.C.D

    Но у меня нет в выборе pptp, а только l2tp и все.

    что делать не поможете.

    Согласно этой инструкции сказано:
    "First and foremost, you need to enter the service internal command. This command is used to enable some hidden IOS features and commands including the PPTP client functionality."
    На русском: "Эта команда позволяет использовать некоторые скрытые в IOS возможности и команды включая команды для PPTP клиента".
    В Вашем конфиге я не увидел данной команды.


  • отредактировано июня 2016
    Спасибо за подсказку, я пробовал ее вводить, и TAB ее не дописывал.
    Написал руками, все подошло.
    СПАСИБО!
  • mitushinem написал:

    Спасибо за подсказку, я пробовал ее вводить, и TAB ее не дописывал.
    Написал руками, все подошло.
    СПАСИБО!

    Рад, что получилось, правда не понял Вы о какой именно команде говорите?
    service internal
    или о других?
  • да именно об service internal
  • Хочу выложить конечный точно рабочий кусок конфига для подключения CISCO к провайдеру по протоколу PPTP.

    service internal
    !
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pptp
    rotary-group 0
    initiate-to ip IP_ADDRESS_VPV_SERVER
    !
    interface Dialer0
    mtu 1460
    ip address negotiated
    ip pim dense-mode
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 1
    ppp pfc local request
    ppp pfc remote apply
    ppp chap hostname _LOGIN_
    ppp chap password 7 _PASSWORD_
    !
    dialer-list 1 protocol ip permit
    !
    ip nat inside source list NAT interface Dialer0 overload
    !
    ip access-list extended NAT
    permit ip 10.2.1.0 0.0.0.255 any
    !
    ip nat inside source list NAT interface Dialer0 overload
    ip route 0.0.0.0 0.0.0.0 Dialer0

    Вдруг кому поможет.
    Очень мало информации по этой теме.
  • Как починил свой NAT то?
  • А пока еще никак )))
    Топик в другом разделе
    forum.linkmeup.ru/index.php?p=/discussion/130/neponyatnyy-nat-na-cisco-1921-k9#latest
Войдите или Зарегистрируйтесь чтобы комментировать.