Привет, незнакомец!

Похоже, вы здесь новенький. Чтобы принять участие, нажмите одну из кнопок ниже!

Настройка OTV на Cisco ASR

Коллеги, всем доброго дня. Требуется помощь. Есть два ЦОДа, пытаюсь настроить OTV между ними, с одной стороны ASR1002 (он используется как unicast otv adjacency-server ), с другой ASR1002-X. Через OTV Растягиваю 990 vlan. За ASRми стоят коммутаторы на которых поднят SVI vlan990, проблем в том что, Otv поднимается, а вот пинг между SVI не ходит. Полная конфигурация ниже:

ЦОД1
ASR1
otv site bridge-domain 225
otv fragmentation join-interface GigabitEthernet0/1/0.2271
otv site-identifier 0000.0000.0001
!
interface Overlay1
no ip address
otv join-interface GigabitEthernet0/1/0.2271
otv adjacency-server unicast-only
service instance 990 ethernet
encapsulation dot1q 990
bridge-domain 990
!
interface GigabitEthernet0/1/0.2271
description VPN to DC2
encapsulation dot1Q 2271
ip address 10.230.152.5 255.255.255.252
end
!
interface GigabitEthernet0/1/3
description Trunk to Catalyst 6500
no ip address
negotiation auto
service instance 225 ethernet
encapsulation dot1q 225
bridge-domain 225
!
service instance 990 ethernet
encapsulation dot1q 990
bridge-domain 990
!
end

Catalyst 6500

interface GigabitEthernet1/12
description Trunk to ASR OTV-TEST
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 225,990
switchport mode trunk
end
!
interface Vlan990
ip address 10.217.0.1 255.255.255.0
end


ЦОД2
ASR2
otv site bridge-domain 225
otv fragmentation join-interface GigabitEthernet0/0/5.2271
otv site-identifier 0000.0000.0002
!
interface Overlay1
no ip address
otv join-interface GigabitEthernet0/0/5.2271
otv use-adjacency-server 10.230.152.5 unicast-only
service instance 990 ethernet
encapsulation dot1q 990
bridge-domain 990
!
end
!
interface GigabitEthernet0/0/5.2271
description VPN to DC1
encapsulation dot1Q 2271
ip address 10.230.152.6 255.255.255.252
end
!
interface GigabitEthernet0/1/2
description Trunk to Nexus
no ip address
negotiation auto
service instance 225 ethernet
encapsulation dot1q 225
bridge-domain 225
!
service instance 990 ethernet
encapsulation dot1q 990
bridge-domain 990
!
end


Nexus

interface Ethernet3/20
description Trunk to ASR
switchport
switchport mode trunk
switchport trunk allowed vlan 225,990
no shutdown
end
!
interface Vlan990
no shutdown
ip address 10.217.0.4/24
end
Тэги темы:

Комментарии

  • Если все еще актуально, ответьте на вопросы:
    Что в вашем понимании поднятый otv? State UP в show otv?
    У вас isis up? У вас isis database одинакова на обоих устройствах?

    Show otv isis neighbor? UP?
    Show otv isis database - одинаковы на обоих раутерах?
    Show otv route vlan 990 - есть маки с удаленного сайта?
    Ну и show otv arp-nd-cache - что там?
  • Под поднятым OTV я имел ввиду, то что сайт поднялся
    OTV-Site up up
    Так же AED Capable на обоих роутерах в значении YES

    ASR1#sh otv
    Overlay Interface Overlay1
    VPN name : None
    VPN ID : 4
    State : UP
    AED Capable : Yes

    ASR2#sh otv
    Overlay Interface Overlay1
    VPN name : None
    VPN ID : 6
    State : UP
    Fwd-capable : Yes
    Fwd-ready : Yes
    AED-Server : Yes
    Backup AED-Server : No
    AED Capable : Yes

    C ISIS тоже вроде все в порядке

    Tag Overlay1:
    System Id Type Interface IP Address State Holdtime Circuit Id
    ASR2 L1 Ov1 172.17.172.2 UP 27 ASR1.01
    Tag Site:
    System Id Type Interface IP Address State Holdtime Circuit Id


    Tag Overlay1:
    System Id Type Interface IP Address State Holdtime Circuit Id
    ASR1 L1 Ov1 172.17.172.1 UP 8 ASR1.01

    Tag Site:
    System Id Type Interface IP Address State Holdtime Circuit Id

    ASR1#sh otv isis database
    Tag Overlay1:
    IS-IS Level-1 Link State Database:
    LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
    ASR2.00-00 0x00000032 0x7377 470 0/0/0
    ASR1.00-00 * 0x00000070 0xAFFD 1076 0/0/0
    ASR1.01-00 * 0x0000001C 0x5EF2 929 0/0/0

    ASR2#sh otv isis database
    Tag Overlay1:
    IS-IS Level-1 Link State Database:
    LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
    ASR2.00-00 * 0x00000033 0x7178 1133 0/0/0
    ASR1.00-00 0x00000070 0xAFFD 1007 0/0/0
    ASR1.01-00 0x0000001C 0x5EF2 860 0/0/0

    Маки с удаленных сайтов есть на обоих роутерах

    ASR1#sh otv route

    Codes: BD - Bridge-Domain, AD - Admin-Distance,
    SI - Service Instance, * - Backup Route

    OTV Unicast MAC Routing Table for Overlay1

    Inst VLAN BD MAC Address AD Owner Next Hops(s)
    ----------------------------------------------------------
    0 990 990 0050.568e.3f0f 40 BD Eng Gi0/1/3:SI990
    0 990 990 0050.56ad.1f18 50 ISIS ASR2
    0 990 990 e4c7.220e.5ec1 50 ISIS ASR2
    0 990 990 e4c7.2211.07c3 50 ISIS ASR2

    4 unicast routes displayed in Overlay1

    ----------------------------------------------------------
    4 Total Unicast Routes Displayed



    ASR2#sh otv route

    Codes: BD - Bridge-Domain, AD - Admin-Distance,
    SI - Service Instance, * - Backup Route

    OTV Unicast MAC Routing Table for Overlay1

    Inst VLAN BD MAC Address AD Owner Next Hops(s)
    ----------------------------------------------------------
    0 990 990 0050.568e.3f0f 50 ISIS ASR1
    0 990 990 0050.56ad.1f18 40 BD Eng Gi0/1/2:SI990
    0 990 990 e4c7.220e.5ec1 40 BD Eng Gi0/1/2:SI990
    0 990 990 e4c7.2211.07c3 40 BD Eng Gi0/1/2:SI990

    4 unicast routes displayed in Overlay1

    ----------------------------------------------------------
    4 Total Unicast Routes Displayed



    А вот в выводе show otv arp-nd-cache на обоих роутерах пусто.




Войдите или Зарегистрируйтесь чтобы комментировать.