Привет, незнакомец!

Похоже, вы здесь новенький. Чтобы принять участие, нажмите одну из кнопок ниже!

In this Discussion

Нужна помощь в настройке pppoe atm client на cisco

Добрый день !

До этого не было особого опыта работы с pppoe и вообще ни какого с интерфейсами atm.
Уже долго мучаюсь, ни как не могу подобрать правильную конфигурацию для клиента pppoe.
Клиент cisco c1900 подключён через atm0/0/0.500 к DISLAM а тот уже подсоединяется к cisco server router.
Большинство примеров показанных в интернете используют vpdn-group с настройкой protocol pppoe,
Мой циско не поддерживает настройку protocol pppoe, только L2TP.

Буду рад если кто-нибудь сможет помочь в настройке pppoe client через atm.

##############################Вот настройка Roter server##########################################

!
username cisco pass cisco
!
bba-group pppoe GROUPA
virtual-template 1
!
!

!
interface Loopback0
ip address 10.12.0.1 255.255.255.0
ipv6 address 2001:6::1/64
ipv6 enable
!

!
interface GigabitEthernet0/1.500
encapsulation dot1Q 500
pppoe enable group GROUPA
ipv6 address 2001:2::1/64
ipv6 enable
ipv6 nd managed-config-flag
ipv6 dhcp server dhcpv6
!

!
interface Virtual-Template1
ip unnumbered Loopback0
ipv6 unnumbered Loopback0
ipv6 enable
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 nd router-preference High
no ipv6 nd ra suppress
ipv6 dhcp server dhcpv6
peer default ip address pool ppppool1
peer default ipv6 pool dhcpv6-pool1
ppp authentication pap chap ms-chap ms-chap-v2
!
ip local pool ppppool1 10.12.0.50 10.12.0.254
!
ipv6 local pool dhcpv6-pool1 2001:5::/32 48

######################Моя пробная настойка для клиента:###########################################
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
hold-queue 224 in
!
interface ATM0/0/0.500 point-to-point
pvc 0/35
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username arko password 0 arko
ppp multilink
no cdp enable
!

Комментарии

  • В жизни с такой схемой не сталкивался, но в теории чтобы это работало DISLAM должен прозрачно (без роутинга) переводить atm фреймы pvc 0/35 в ethernet фреймы влан 500. Так что посмотрите настройки DISLAM и убедитесь что такая связность есть (настройте ip из одной подсети на interface ATM0/0/0.500 клиента и interface GigabitEthernet0/1.500 сервера и попингуйте). Потом только игра с настройками pppoe (а они, в целом, вроде похожи на то, что должно быть).
  • legion написал:

    В жизни с такой схемой не сталкивался, но в теории чтобы это работало DISLAM должен прозрачно (без роутинга) переводить atm фреймы pvc 0/35 в ethernet фреймы влан 500. Так что посмотрите настройки DISLAM и убедитесь что такая связность есть (настройте ip из одной подсети на interface ATM0/0/0.500 клиента и interface GigabitEthernet0/1.500 сервера и попингуйте). Потом только игра с настройками pppoe (а они, в целом, вроде похожи на то, что должно быть).

    DISLAM работает исправно, есть клиенсткие роутеры других вендоров, которые работают, застрял только с настройкой cisco c1900, не совсем понятно как его правильно настроить, в интернете есть примеры, но не все команды с1900 потдерживает, хотя licence присутствует.
  • Был не прав, все оказалось немного сложнее. Посмотрите здесь может поможет.
Войдите или Зарегистрируйтесь чтобы комментировать.