UNL проблемы и решения

2456

Комментарии

  • Не пингуются роутеры в одной подсети, модель обоих 1710. Дамп трафика показал arp incomplete. Кто нибудь сталкивался с подобным?
  • Anumrak написал:

    Не пингуются роутеры в одной подсети, модель обоих 1710. Дамп трафика показал arp incomplete. Кто нибудь сталкивался с подобным?

    После перезапуска виртуалки и лабы, арп долетел.
  • У меня вот в IOU роутерах не работает LDP на саб интерфейсах, через IOU коммутатор. Без сабов все поднимается, это ограничение IOU образа или трабл в UNL ?
  • artmc написал:

    У меня вот в IOU роутерах не работает LDP на саб интерфейсах, через IOU коммутатор. Без сабов все поднимается, это ограничение IOU образа или трабл в UNL ?

    На L2 попробуйте
    # no ip igmp snooping
  • пробовал, не помогает.
  • artmc написал:

    У меня вот в IOU роутерах не работает LDP на саб интерфейсах, через IOU коммутатор. Без сабов все поднимается, это ограничение IOU образа или трабл в UNL ?

    На UNL 1.0.0-6 ldp соседство поднимается на сабах. Можно попробовать включать не через mpls ip на сабинтерфейсе, а через mpls ldp autoconfig в режиме конфигурации IGP. Хотя скорее всего что-то не то с конфигурацией L2 свича. Или просто по каким-то причинам нет базовой ip связности
  • Связность есть, конфигурации свича в норме, ospf на этих сабах поднимается, мультикаст адрес 224.0.0.5 пингается, а ldp использует мультикаст 224.0.0.2 он не пингается на сабах
  • У меня в веб-интерфейсе (во всех браузерах) не появляется кнопка "Open" справа от названия лабы Linkmeup.unl (да и любой другой лабы). Просто белый экран справа от списка лаб.

    Образ unl скачал линкмиаповский.
    PC старый: Intel Core2 Duo 3.16GHz E8500, 4 Gb RAM, Win7 x64, поддержки VTx нет. Антивирус отключил.

    У меня проблема с железом или софтом?
  • Moonshiner написал:

    У меня в веб-интерфейсе (во всех браузерах) не появляется кнопка "Open" справа от названия лабы Linkmeup.unl (да и любой другой лабы). Просто белый экран справа от списка лаб.

    Образ unl скачал линкмиаповский.
    PC старый: Intel Core2 Duo 3.16GHz E8500, 4 Gb RAM, Win7 x64, поддержки VTx нет. Антивирус отключил.

    У меня проблема с железом или софтом?

    double click?
  • отредактировано Апрель 2016
    Кто знает как реализовать нормальные хосты в лабе? Хосты в виде роутеров не устраивают. Комп "Windows" ставлю, а так чтобы можно было там интерфейс конфигурировать, не получается. Пользуюсь Windows integration pack для автоматического telnet.
  • Мы у себя используем в качестве хостов для теста Fedora 23 Cloud https://getfedora.org/ru/cloud/download/. Маленький готовый образ.
  • Jay-T написал:

    Мы у себя используем в качестве хостов для теста Fedora 23 Cloud https://getfedora.org/ru/cloud/download/. Маленький готовый образ.

    Спасибо, вечером опробую.
  • отредактировано Апрель 2016
    Anumrak написал:

    Кто знает как реализовать нормальные хосты в лабе? Хосты в виде роутеров не устраивают. Комп "Windows" ставлю, а так чтобы можно было там интерфейс конфигурировать, не получается. Пользуюсь Windows integration pack для автоматического telnet.

    Берете ставите на VMware например Windows или что хотите

    Конвертируете в qcow2

    готово )

    либо качаете любой готовый образ в qcow2 формате, кладете в папку с win- linux-
  • Anumrak написал:

    Кто знает как реализовать нормальные хосты в лабе? Хосты в виде роутеров не устраивают. Комп "Windows" ставлю, а так чтобы можно было там интерфейс конфигурировать, не получается. Пользуюсь Windows integration pack для автоматического telnet.

    В скором времени может появится поддержка VPCS в UNL
  • отредактировано Апрель 2016
    Спасибо всем, попробую оба варианта. Надеюсь что будут аналоги хостов хотя бы как в packet tracer.
  • Jay-T написал:

    Мы у себя используем в качестве хостов для теста Fedora 23 Cloud https://getfedora.org/ru/cloud/download/. Маленький готовый образ.

    Попробовал, скачал, создал папку в /opt/unetlab/addons/qemu/linux-fedora-image/
    туда положил файл образа qcow2 (переименовав) linux-fedora-image.qcow2
    Захожу в UNL добавляю Node выбираю Linux там вижу название "linux-fedora-image", нода добавляется но не стартует. Ошибок не выдает.
    Попробовал скачать LiveCD с образом .iso создал папку /opt/unetlab/addons/qemu/linux-rfremix-12-livecd в нее залил образ переименовав его в cdrom.iso
    Аналогично, добавляю ноду, но она не стартует :(
  • Также и по умолчанию Windows нод не стартует.
  • все образа, должны ОБЯЗАТЕЛЬНо правильно называться в папке qemu
    win-
    linux-

    внутри либо hda.qcow2 либо virtioa.qcow2

    обратите внимание на расширение и на название, они обязательны.

    если например двух дисковые системы hda.qcow2 hdb.qcow2 как ASA
  • отредактировано Апрель 2016
    Если вы уверены, что все правильно положили и назвали, но всеравно не стартует, сделайте /opt/unetlab/wrappers/unl_wrapper -a fixpermissions
  • DimQ написал:

    все образа, должны ОБЯЗАТЕЛЬНо правильно называться в папке qemu
    win-
    linux-

    внутри либо hda.qcow2 либо virtioa.qcow2

    обратите внимание на расширение и на название, они обязательны.
    если например двух дисковые системы hda.qcow2 hdb.qcow2 как ASA

    То есть, скаченный образ (например) Fedora-Cloud-Base-23-20151030.x86_64.qcow2 я должен переименовать в hda.qcow2? Естественно, предварительно положив его в созданную папку linux-fedora, папку созданную в каталоге /opt/unetlab/addons/qemu/
    Попробовал, не помогло
    /opt/unetlab/wrappers/unl_wrapper -a fixpermissions
    запускал

    root@unl01:~# ls -l /opt/unetlab/addons/qemu/linux-fedora-image/
    total 228876
    -rw-r--r-- 1 root root 234363392 Apr 4 10:10 hda.qcow2
  • /opt/unetlab/addons/qemu/linux-fedora/hda.qcow2
    Сделайте так. Образы qemu должны лежать в директориях с определенным названием в начале. Например, если ставить хотите положить Ubuntu, то директория в qemu должна быть linux-ubuntu, или linux-whateverGUIMorePain. Ну и /opt/unetlab/wrappers/unl_wrapper -a fixpermissions сделайте, да.
    По поводу других образов должно начинаться так, как указано на картинке.
  • отредактировано Апрель 2016
    Вы 100% уверены, что вы вообще можете запускать qemu? у вас как kvm ok?) ( VT )
  • feo_sobolev написал:

    DimQ написал:

    все образа, должны ОБЯЗАТЕЛЬНо правильно называться в папке qemu
    win-
    linux-

    внутри либо hda.qcow2 либо virtioa.qcow2

    обратите внимание на расширение и на название, они обязательны.
    если например двух дисковые системы hda.qcow2 hdb.qcow2 как ASA

    То есть, скаченный образ (например) Fedora-Cloud-Base-23-20151030.x86_64.qcow2 я должен переименовать в hda.qcow2? Естественно, предварительно положив его в созданную папку linux-fedora, папку созданную в каталоге /opt/unetlab/addons/qemu/
    Попробовал, не помогло
    /opt/unetlab/wrappers/unl_wrapper -a fixpermissions
    запускал

    root@unl01:~# ls -l /opt/unetlab/addons/qemu/linux-fedora-image/
    total 228876
    -rw-r--r-- 1 root root 234363392 Apr 4 10:10 hda.qcow2

    rename to cdrom.iso


    howto -

  • michaely написал:


    rename to cdrom.iso
    howto -

    Пробую:

    root@unl01:~# ls -l /opt/unetlab/addons/qemu/linux-fedora-image/
    total 228876
    -rw-r--r-- 1 root root 234363392 Apr 4 10:10 cdrom.iso
    Эффект, к сожалению тот-же,
    После старта, она остается выключенной, и в инфо показывает что запущено 0 машин
  • отредактировано Апрель 2016
    Еще раз, вы уверены что у вас VT работает?


    123.jpg 157.3K
    1234.jpg 10.8K
  • DimQ написал:

    Еще раз, вы уверены что у вас VT работает?

    Буду признателен, если подскажите каким образом проверить?
    Ничего дополнительного не ставил в образ. Образ брал инструкторский.
  • отредактировано Апрель 2016
    :)

    kvm-ok я не шутил

    и

    egrep '(vmx|svm)' --color=always /proc/cpuinfo

    vmx для intel svm для amd

    должно быть выделено в инструкциях
  • отредактировано Апрель 2016
    DimQ написал:

    :)
    kvm-ok я не шутил
    и
    egrep '(vmx|svm)' --color=always /proc/cpuinfo
    vmx для intel svm для amd
    должно быть выделено в инструкциях

    Параметр "vmx" отсутствует. Процессор Intel.
    Выходит, что не поддерживается?
    Вероятно, проблема в этом?
    VMware.png 76.2K
  • отредактировано Апрель 2016
    у вас что ESXi? Workstation? Baremetal?
  • DimQ написал:

    у вас что ESXi? Workstation? Baremetal?

    WorkStation 10.0.3 build-1895310
    Кстати, она изначально по-дефолту не захотела кушать образ .ova, я его в ручную конвертировал через ovftool
Войдите или Зарегистрируйтесь чтобы комментировать.