UNL проблемы и решения

1246

Комментарии

  • Moonshiner написал:

    DimQ написал:

    Сначала можно проверить так, работает ли у Вас VT-x https://www.grc.com/securable.htm

    Потом обновить BIOS, попробовать выключить включить технологию и тп

    Проверить еще раз

    Утилита показала, что VT-x работает, включил выключил, но UNL все равно мой VTX не признает.

    2michaely: что кроме процессора и системы виртуализации должно поддерживать VT-x?
    Видео в youtubе не дали ответа?
  • Столкнулся с интересным багом, в момент остановки всех запущенных нод, все исчезло и вылезла ошибка что лаба не найдена. Полез в консоль, действительно, unl файл с лабой исчез. При этом в /opt/unetlab/tmp директория с id лабы и всем содержимым осталась. Не знаю, то ли это глюк конкретно моего железа, то ли unetlab.
  • shweik написал:

    Столкнулся с интересным багом, в момент остановки всех запущенных нод, все исчезло и вылезла ошибка что лаба не найдена. Полез в консоль, действительно, unl файл с лабой исчез. При этом в /opt/unetlab/tmp директория с id лабы и всем содержимым осталась. Не знаю, то ли это глюк конкретно моего железа, то ли unetlab.

    Странно, будем проверять
  • @shweik , Пошли мне логи или тут прикрути - /opt/unetlab/data/Logs

    access.txt
    api.txt
    error.txt
    php_errors.txt
    unl_wrapper.txt

    Лаб с проблемой новый, сам делал или уже был создан?
  • Михаил привет!

    Ещё косячек выплыл, но скорее с IOL.
    Если хотим натом поиграться...

    R1(config-subif)#ip nat inside
    % NBAR Error: LEXER error : parsing stopped

    % NBAR Error: Activation failed due to insufficient Dynamic Memory
    % NBAR Error: Stile could not add protocol node
    %NAT: Error activating CNBAR on the interface Ethernet0/0.5

    И если ноду перезагрузить (из CLI или вебморды), то все можно смело чистить конфиг потому что она больше не запустится :)

    На этих IOL проблема:
    L3-ADVENTERPRISEK9-M-15.4-1T.bin
    L3-ADVENTERPRISEK9-M-15.4-2T.bin
    L3-ADVENTERPRISEK9-M-15.3-1.3T.bin (ошибок не выдает, но после перезагрузке отваливается)

    На этом норм:
    L3-ADVENTERPRISEK9-M-15.2-4M1.bin


    Версия unetlab свежайшая.

    dpkg -l | grep unetlab
    ii linux-headers-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.Custom amd64
    ii linux-image-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.Custom amd64
    ii unetlab 1.0.0-6 amd64
    ii unetlab-dynamips 0.8.6-44 amd64
    ii unetlab-qemu 1.0.0-6 amd64
  • NAT_GTX написал:

    Михаил привет!

    Ещё косячек выплыл, но скорее с IOL.
    Если хотим натом поиграться...

    R1(config-subif)#ip nat inside
    % NBAR Error: LEXER error : parsing stopped

    % NBAR Error: Activation failed due to insufficient Dynamic Memory
    % NBAR Error: Stile could not add protocol node
    %NAT: Error activating CNBAR on the interface Ethernet0/0.5

    И если ноду перезагрузить (из CLI или вебморды), то все можно смело чистить конфиг потому что она больше не запустится :)

    На этих IOL проблема:
    L3-ADVENTERPRISEK9-M-15.4-1T.bin
    L3-ADVENTERPRISEK9-M-15.4-2T.bin
    L3-ADVENTERPRISEK9-M-15.3-1.3T.bin (ошибок не выдает, но после перезагрузке отваливается)

    На этом норм:
    L3-ADVENTERPRISEK9-M-15.2-4M1.bin


    Версия unetlab свежайшая.

    dpkg -l | grep unetlab
    ii linux-headers-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.Custom amd64
    ii linux-image-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.Custom amd64
    ii unetlab 1.0.0-6 amd64
    ii unetlab-dynamips 0.8.6-44 amd64
    ii unetlab-qemu 1.0.0-6 amd64

    Больше РАМа и НВРАМа дай и должно быть ОК
  • отредактировано апреля 2016
    michaely написал:

    NAT_GTX написал:

    Михаил привет!

    Ещё косячек выплыл, но скорее с IOL.
    Если хотим натом поиграться...

    R1(config-subif)#ip nat inside
    % NBAR Error: LEXER error : parsing stopped

    % NBAR Error: Activation failed due to insufficient Dynamic Memory
    % NBAR Error: Stile could not add protocol node
    %NAT: Error activating CNBAR on the interface Ethernet0/0.5

    И если ноду перезагрузить (из CLI или вебморды), то все можно смело чистить конфиг потому что она больше не запустится :)

    На этих IOL проблема:
    L3-ADVENTERPRISEK9-M-15.4-1T.bin
    L3-ADVENTERPRISEK9-M-15.4-2T.bin
    L3-ADVENTERPRISEK9-M-15.3-1.3T.bin (ошибок не выдает, но после перезагрузке отваливается)

    На этом норм:
    L3-ADVENTERPRISEK9-M-15.2-4M1.bin


    Версия unetlab свежайшая.

    dpkg -l | grep unetlab
    ii linux-headers-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.Custom amd64
    ii linux-image-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.Custom amd64
    ii unetlab 1.0.0-6 amd64
    ii unetlab-dynamips 0.8.6-44 amd64
    ii unetlab-qemu 1.0.0-6 amd64

    Больше РАМа и НВРАМа дай и должно быть ОК
    Есть контакт, добавил РАМ 350 против 256 все гуд.
    Спасибо :)
  • michaely написал:

    @shweik , Пошли мне логи или тут прикрути - /opt/unetlab/data/Logs

    access.txt
    api.txt
    error.txt
    php_errors.txt
    unl_wrapper.txt

    Лаб с проблемой новый, сам делал или уже был создан?

    Михаил,приветствую. По логам у меня следующая ситуация:
    php_errors отсутствует вовсе, api.txt и error.txt пустые, в access.txt и unl_wrapper.txt записи начинаются со времени после ошибки, если нужны могу прислать(ну я просто к тому что в них тоже инфы никакой). Может где-то еще логи какие есть системные к примеру ? Лабу делал сам, это полная топология была по СДСМ.

    Версия unetlab следующая:
    dpkg -l | grep unetlab
    ii linux-headers-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.
    ii linux-image-3.16.7-ckt8-unetlab 3.16.7-ckt8-unetlab-10.00.
    ii unetlab 1.0.0-6.
    ii unetlab-dynamips 0.8.6-44
    ii unetlab-qemu 1.0.0-6
  • Последняя команда связанная с этой лабой в auth.log такая
    sudo: www-data : TTY=unknown ; PWD=/opt/unetlab/html ; USER=root ; COMMAND=/opt/unetlab/wrappers/unl_wrapper -a export -T 0 -D 25 -F /opt/unetlab/labs/SDSM LInkmeup/SDSM Network ALL.unl
    После этого упоминаний о лабе нигде нет.
  • shweik написал:

    Последняя команда связанная с этой лабой в auth.log такая
    sudo: www-data : TTY=unknown ; PWD=/opt/unetlab/html ; USER=root ; COMMAND=/opt/unetlab/wrappers/unl_wrapper -a export -T 0 -D 25 -F /opt/unetlab/labs/SDSM LInkmeup/SDSM Network ALL.unl
    После этого упоминаний о лабе нигде нет.

    Будем смотреть. Файл с лабой стерся?
  • michaely написал:

    shweik написал:

    Последняя команда связанная с этой лабой в auth.log такая
    sudo: www-data : TTY=unknown ; PWD=/opt/unetlab/html ; USER=root ; COMMAND=/opt/unetlab/wrappers/unl_wrapper -a export -T 0 -D 25 -F /opt/unetlab/labs/SDSM LInkmeup/SDSM Network ALL.unl
    После этого упоминаний о лабе нигде нет.

    Будем смотреть. Файл с лабой стерся?
    Михаил приветствую. Да сам файл .unl с лабой потерся. Но как я и писал выше, в /opt/unetlab/tmp директория с id лабы и всем содержимым осталась.
  • отредактировано апреля 2016
    Здравствуйте.
    Добавил в лабу роутер MIKROTIK. Подключаюсь через VNC к адресу 192.168.215.128:32770 - всё нормально работает - вижу консоль микроши. Как подключиться к этому же роутеру с помощью Winbox(фирменный клиент от Mikrotik)? Софтина ломится на порт по умолчанию 8291, но ничего не находит.
  • Winbox'ом можно по маку подключаться, если виртуальная машина с UNL и физический компьютер в одном броадкаст домене
  • В курсе, что можно. Но и МАСа не видит. Сегмент сети один и тот-же.
  • отредактировано апреля 2016
    michaely написал:

    shweik написал:

    Последняя команда связанная с этой лабой в auth.log такая
    sudo: www-data : TTY=unknown ; PWD=/opt/unetlab/html ; USER=root ; COMMAND=/opt/unetlab/wrappers/unl_wrapper -a export -T 0 -D 25 -F /opt/unetlab/labs/SDSM LInkmeup/SDSM Network ALL.unl
    После этого упоминаний о лабе нигде нет.

    Будем смотреть. Файл с лабой стерся?
    Михаил, приветствую. Сегодня повторилась ситуация с исчезновением лабы. Точная ситуация следующая:
    Если присутствуют запущенные qemu linux хосты и при этом выполнить Export all CFG, то на выходе получаем Lab does not exist (60000).

    Прикладываю скрин ситуации на момент возникновения ошибки и логи из /opt/unetlab/data/Logs. После этого исчезает unl файл лабы, но сами объекты остаются.

    Прошу прощения что ввел в заблуждение в предыдущих постах, неправильным определением события возникновения ошибки.
    logs.tgz 191.3K
  • shweik написал:

    michaely написал:

    shweik написал:

    Последняя команда связанная с этой лабой в auth.log такая
    sudo: www-data : TTY=unknown ; PWD=/opt/unetlab/html ; USER=root ; COMMAND=/opt/unetlab/wrappers/unl_wrapper -a export -T 0 -D 25 -F /opt/unetlab/labs/SDSM LInkmeup/SDSM Network ALL.unl
    После этого упоминаний о лабе нигде нет.

    Будем смотреть. Файл с лабой стерся?
    Михаил, приветствую. Сегодня повторилась ситуация с исчезновением лабы. Точная ситуация следующая:
    Если присутствуют запущенные qemu linux хосты и при этом выполнить Export all CFG, то на выходе получаем Lab does not exist (60000).

    Прикладываю скрин ситуации на момент возникновения ошибки и логи из /opt/unetlab/data/Logs. После этого исчезает unl файл лабы, но сами объекты остаются.

    Прошу прощения что ввел в заблуждение в предыдущих постах, неправильным определением события возникновения ошибки.
    можешь экспорт лаба сделать и послать мне?
  • michaely написал:

    shweik написал:

    michaely написал:

    shweik написал:

    Последняя команда связанная с этой лабой в auth.log такая
    sudo: www-data : TTY=unknown ; PWD=/opt/unetlab/html ; USER=root ; COMMAND=/opt/unetlab/wrappers/unl_wrapper -a export -T 0 -D 25 -F /opt/unetlab/labs/SDSM LInkmeup/SDSM Network ALL.unl
    После этого упоминаний о лабе нигде нет.

    Будем смотреть. Файл с лабой стерся?
    Михаил, приветствую. Сегодня повторилась ситуация с исчезновением лабы. Точная ситуация следующая:
    Если присутствуют запущенные qemu linux хосты и при этом выполнить Export all CFG, то на выходе получаем Lab does not exist (60000).

    Прикладываю скрин ситуации на момент возникновения ошибки и логи из /opt/unetlab/data/Logs. После этого исчезает unl файл лабы, но сами объекты остаются.

    Прошу прощения что ввел в заблуждение в предыдущих постах, неправильным определением события возникновения ошибки.
    можешь экспорт лаба сделать и послать мне?
    Михаил, отправил.
  • Коллеги скажите пожалуйста кто пробовал запускать IOS XRv? Я все сделал по инструкции http://www.unetlab.com/2014/11/adding-cisco-xrv-images/, но после запуска ноды XR в лабе не старуует и через секунды 3 переходит в состояние stop. Такая же проблемы и с Juniper оборудованием. Все версии запускал поддерживаемые UNL. Весрия XRv xrv-k9-5.2.2.
  • Может быть, памяти не хватает? Для XRv надо 2-3 Гб. Или не поддерживается вложенная виртуализация, это можно проверить, сделав grep flags /proc/cpuinfo в виртуальной машине. В выводе должно быть vmx (для процессоров Intel) или svm (для процессоров AMD)
  • С памятью и процами нет проблем. UNL установлен на рабочем ESXi, пробовал добволять до 10 ГБ памяти и 4 CPUна один XR, не помогло. Образ quemi ASA запускается без проблем. Процессоры Intel.
  • отредактировано апреля 2016
    Добрый день,
    подскажите, если коммутаторы IOL (образ L2-IRON) автосогласовываются на скорости 10 Мбит/с - это нормальное поведение для эмулятора? От чего это зависит?

  • В новейшей версии заработал XRv во вложенной виртуализации, пацаны ваще ребята :)
  • Всем добрый день.
    Сломал голову при поиске образа L2: никак не могу сопоставить название L2-ADVENTERPRISEK9-M-15.2-IRON-20151103.bin с названием в IOU (i86bi-linux-l2-adventerprisek9-....). Под "*-IRON-20151103.bin" ничего не нашел :(

    Подскажите, пожалуйста, название образа L2 в IOU. Заранее благодарен
    *P.S.: обучение в самом разгаре, а я буксую на ровном месте...
  • bvesel написал:

    Всем добрый день.
    Сломал голову при поиске образа L2: никак не могу сопоставить название L2-ADVENTERPRISEK9-M-15.2-IRON-20151103.bin с названием в IOU (i86bi-linux-l2-adventerprisek9-....). Под "*-IRON-20151103.bin" ничего не нашел :(

    Подскажите, пожалуйста, название образа L2 в IOU. Заранее благодарен
    *P.S.: обучение в самом разгаре, а я буксую на ровном месте...

    Скачай linkmeup Сборку
  • michaely написал:

    bvesel написал:

    Всем добрый день.
    Сломал голову при поиске образа L2: никак не могу сопоставить название L2-ADVENTERPRISEK9-M-15.2-IRON-20151103.bin с названием в IOU (i86bi-linux-l2-adventerprisek9-....). Под "*-IRON-20151103.bin" ничего не нашел :(

    Подскажите, пожалуйста, название образа L2 в IOU. Заранее благодарен
    *P.S.: обучение в самом разгаре, а я буксую на ровном месте...

    Скачай linkmeup Сборку
    Спасибо.
  • отредактировано апреля 2016
    В консоли:

    SW1#sh run | s 0/0
    interface Ethernet0/0
    shutdown

    В выгруженном конфиге:

    interface Ethernet0/0
    no shutdown
    shutdown

    Из-за этого не совпадение при сравнении моего например конфига с предоставленными ответами (В которых вообще например не присутствует shutdown или no shutdown).

    UNetLab version: 1.0.0-8
  • Admics написал:

    В консоли:

    SW1#sh run | s 0/0
    interface Ethernet0/0
    shutdown

    В выгруженном конфиге:

    interface Ethernet0/0
    no shutdown
    shutdown

    Из-за этого не совпадение при сравнении моего например конфига с предоставленными ответами (В которых вообще например не присутствует shutdown или no shutdown).

    UNetLab version: 1.0.0-8

    это фичер, дам немного подумать для чего. :)
  • отредактировано апреля 2016
    michaely написал:


    это фичер, дам немного подумать для чего. :)

    Что бы по умолчанию интерфейс поднимался, если в конфиге интерфейс явно не включен? Или иное что?

  • Admics написал:

    michaely написал:


    это фичер, дам немного подумать для чего. :)

    Что бы по умолчанию интерфейс поднимался, если в конфиге интерфейс явно не включен? Или иное что?

    Kogda export config delaesh iz devisa u korogo vklucheni interfasi "no shut" v show run netu, poetomu kogda startuesh device s exported config, interfaci nujno rukami podnimat.

    Etot feacher dlya togo chtob ne podnimat rukami. Esli sdelaesh export konfiga s interfacom posle "no shut" to uvidish chto v exporte tol'ko "no shut" i est
Войдите или Зарегистрируйтесь чтобы комментировать.