Привет, незнакомец!

Похоже, вы здесь новенький. Чтобы принять участие, нажмите одну из кнопок ниже!

HSRP

2

Комментарии

  • dmfigol написал:

    kamasutr написал:

    dmfigol написал:

    Всё правильно вы описываете. Трекинг - это трекинг, preempt - это preempt. Если preempt отключен, то не Active роутер не вернёт себе Active роль, если уже есть Active. Другой вопрос, когда вы симулировали аварию, перешёл ли роутер в HSRP Disabled state, или он остался Active?

    R1 перешел в Disabled state. R2 был стэндбай и стал эктив. После ремонта. R1 стал проходить по очереди все стадии - листен спикин и тд. И потом стал активом. А R2 стал тенд бай. И это при том что приеемп в дисейбл.
    На свитче spanning tree mode pvst+ и порты не portfast, да?
    Свич из коробки

    На нем натсроек 0. Только все заводское
    Порты не портфаст
    switch.PNG 21.3K
  • Anumrak написал:

    В принципе HSRP нормально работает только тогда, когда tracking включен, иначе приоритет падать не будет ни у кого.
    Камасутр, ты должен понять:
    Preemt для возвращения active и только.
    Tracking - для возможности декрементировать приоритеты у active и у standby и инкрементировать(поднять) приоритет после восстановления наблюдаемого интерфейса.

    Если отключить preemt, то никакого возвращения active не будет. То что ты пишешь не реализуемо в HSRP.
    Если отключить tracking, то приоритеты не будут падать, потому что декрементировать нечем.

    Спасибо за ваше пояснение. У меня вопрос совсем в другом. Я показиваю реальную работу реального оборудования. И у меня получается что - неважно написано дисэйбл или энейбл преемп - он работает так, как будто энебл всегда. Мой вопрос - почему так? Теперь вы поняли мой вопрос?
  • kamasutr написал:

    dmfigol написал:

    kamasutr написал:

    dmfigol написал:

    Всё правильно вы описываете. Трекинг - это трекинг, preempt - это preempt. Если preempt отключен, то не Active роутер не вернёт себе Active роль, если уже есть Active. Другой вопрос, когда вы симулировали аварию, перешёл ли роутер в HSRP Disabled state, или он остался Active?

    R1 перешел в Disabled state. R2 был стэндбай и стал эктив. После ремонта. R1 стал проходить по очереди все стадии - листен спикин и тд. И потом стал активом. А R2 стал тенд бай. И это при том что приеемп в дисейбл.
    На свитче spanning tree mode pvst+ и порты не portfast, да?
    Свич из коробки

    На нем натсроек 0. Только все заводское
    Порты не портфаст
    Ну это и была подсказка :) Когда линк поднимается, он уже показывает up/up, мы начинаем слать HSRP Hello, но они не будут доходить 30 секунд, пока порт на свитче не перейдёт в Forwarding, поэтому мы становимся Active через 10.
  • dmfigol написал:

    kamasutr написал:

    dmfigol написал:

    kamasutr написал:

    dmfigol написал:

    Всё правильно вы описываете. Трекинг - это трекинг, preempt - это preempt. Если preempt отключен, то не Active роутер не вернёт себе Active роль, если уже есть Active. Другой вопрос, когда вы симулировали аварию, перешёл ли роутер в HSRP Disabled state, или он остался Active?

    R1 перешел в Disabled state. R2 был стэндбай и стал эктив. После ремонта. R1 стал проходить по очереди все стадии - листен спикин и тд. И потом стал активом. А R2 стал тенд бай. И это при том что приеемп в дисейбл.
    На свитче spanning tree mode pvst+ и порты не portfast, да?
    Свич из коробки

    На нем натсроек 0. Только все заводское
    Порты не портфаст
    Ну это и была подсказка :) Когда линк поднимается, он уже показывает up/up, мы начинаем слать HSRP Hello, но они не будут доходить 30 секунд, пока порт на свитче не перейдёт в Forwarding, поэтому мы становимся Active через 10.
    А второй роутер находясь в эктиве сравнивает свой приоритет и приоритет первого, видит чтой свой меньше и потому переходит в стенд бай? Ша проверю
  • 1) У вас свитч L2 или L3?
    2) Какие интерфейсы, отвечающие за течение боевого трафика в интернет, следят за падением линка в интернет?

    Чтобы сэкономить общее время, могу сказать, что на моем агрегационном L3 свитче абонентские интерфейсы объединены в standby группу и все они следят за одним outbound интерфейсом в интернет.

    Мне кажется вы не правильно настроили HSRP. Потому что у него получаются два понятия: 1) Боевые интерфейсы ; 2) Интерфейсы, за которыми наблюдают.
  • На счет spanning tree, хорошая догадка)
  • kamasutr написал:

    dmfigol написал:

    kamasutr написал:

    dmfigol написал:

    kamasutr написал:

    dmfigol написал:

    Всё правильно вы описываете. Трекинг - это трекинг, preempt - это preempt. Если preempt отключен, то не Active роутер не вернёт себе Active роль, если уже есть Active. Другой вопрос, когда вы симулировали аварию, перешёл ли роутер в HSRP Disabled state, или он остался Active?

    R1 перешел в Disabled state. R2 был стэндбай и стал эктив. После ремонта. R1 стал проходить по очереди все стадии - листен спикин и тд. И потом стал активом. А R2 стал тенд бай. И это при том что приеемп в дисейбл.
    На свитче spanning tree mode pvst+ и порты не portfast, да?
    Свич из коробки

    На нем натсроек 0. Только все заводское
    Порты не портфаст
    Ну это и была подсказка :) Когда линк поднимается, он уже показывает up/up, мы начинаем слать HSRP Hello, но они не будут доходить 30 секунд, пока порт на свитче не перейдёт в Forwarding, поэтому мы становимся Active через 10.
    А второй роутер находясь в эктиве сравнивает свой приоритет и приоритет первого, видит чтой свой меньше и потому переходит в стенд бай? Ша проверю
    Я не знаю, что происходит, когда оба считают себя Active, но подозреваю, что будет новый election.
    Portfast на портах свитча должен решить проблему.
    Или
    (config-if)# standby delay minimum 25
    на роутерах
  • rpvst проще включить
  • отредактировано Март 2016
    Anumrak написал:

    1) У вас свитч L2 или L3?
    2) Какие интерфейсы, отвечающие за течение боевого трафика в интернет, следят за падением линка в интернет?

    Чтобы сэкономить общее время, могу сказать, что на моем агрегационном L3 свитче абонентские интерфейсы объединены в standby группу и все они следят за одним outbound интерфейсом в интернет.

    Мне кажется вы не правильно настроили HSRP. Потому что у него получаются два понятия: 1) Боевые интерфейсы ; 2) Интерфейсы, за которыми наблюдают.

    Не. Все равно становится первый активом после востановления. Включил РСТП. Свич 3560 является Л3. Я писал. Не пойму вашего второго вопроса. У меня никто не закем не следит.
  • Установите внутренние интерфейсы роутеров в группу standby и их же поставьте трекать внешние интерфейсы, которые смотрят в интернет. Сам же интерфейс, который смотрит в интернет, вообще не конфигурируйте в standby группу.
    Вот как выглядят мои "боевые" интерфейсы:
    interface Vlan2
    description Management
    ip address 172.17.7.2 255.255.255.128
    standby version 2
    standby 1 ip 172.17.7.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan100
    description ASW1&ASW2
    ip address 10.37.0.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.0.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan101
    description ASW1&ASW2
    ip address 10.37.1.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.1.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan102
    description ASW3&ASW4
    ip address 10.37.2.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.2.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan103
    description ASW3&ASW4
    ip address 10.37.3.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.3.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1

    А вот мой интерфейс, на который реагируют вышеописанные vlan интерфейсы:
    interface GigabitEthernet0/1
    description Uplink to GW
    no switchport
    ip address 172.17.7.249 255.255.255.252
    ip summary-address eigrp 100 10.37.0.0 255.255.252.0 5
    duplex auto
    speed auto

    Вообще не имеющий прямого отношения к группе standby.
  • Anumrak написал:

    Установите внутренние интерфейсы роутеров в группу standby и их же поставьте трекать внешние интерфейсы, которые смотрят в интернет. Сам же интерфейс, который смотрит в интернет, вообще не конфигурируйте в standby группу.
    Вот как выглядят мои "боевые" интерфейсы:
    interface Vlan2
    description Management
    ip address 172.17.7.2 255.255.255.128
    standby version 2
    standby 1 ip 172.17.7.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan100
    description ASW1&ASW2
    ip address 10.37.0.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.0.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan101
    description ASW1&ASW2
    ip address 10.37.1.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.1.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan102
    description ASW3&ASW4
    ip address 10.37.2.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.2.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1
    !
    interface Vlan103
    description ASW3&ASW4
    ip address 10.37.3.2 255.255.255.0
    ip helper-address 172.17.7.129
    standby version 2
    standby 1 ip 10.37.3.1
    standby 1 priority 101
    standby 1 preempt
    standby 1 track GigabitEthernet0/1

    А вот мой интерфейс, на который реагируют вышеописанные vlan интерфейсы:
    interface GigabitEthernet0/1
    description Uplink to GW
    no switchport
    ip address 172.17.7.249 255.255.255.252
    ip summary-address eigrp 100 10.37.0.0 255.255.252.0 5
    duplex auto
    speed auto

    Вообще не имеющий прямого отношения к группе standby.

    Так как вы написали - будет работать.
  • Скиньте пожалуйста конфиг рабочей ситуации тогда, когда без preemt R1 перехватывает Active?
  • Anumrak написал:

    Скиньте пожалуйста конфиг рабочей ситуации тогда, когда без preemt R1 перехватывает Active?

    Шоу ран? Я сбрасывал више.
  • Правильно ли я понимаю: на обоих роутерах нет ни трекинга, ни преемпта, и R1 после standby статуса, после восстановлении канала на нем, становится Active?
  • Anumrak написал:

    Правильно ли я понимаю: на обоих роутерах нет ни трекинга, ни преемпта, и R1 после standby статуса, после восстановлении канала на нем, становится Active?

    Правильно
  • отредактировано Март 2016
    И R1 с Active меняется на Standby без трекинга и преемпта, если его линк до свитча сломать?
  • отредактировано Март 2016
    Anumrak написал:

    И R1 с Active меняется на Standby без трекинга и преемпта, если его линк до свитча сломать?

    Нет. переходит в состояние инит. State is Init (interface down)
  • Думаю это потому, что ты ломаешь единственный канал связи до второго hsrp роутера. Он не видит того, с кем бы он мог помериться приоритетами. Попробуй создать топологию такую же, только роутеры между собой связать. L3 ether-channel'ом например.
  • А какой канал ты у R1 ломаешь? До свитча или до интернета?
  • Anumrak написал:

    А какой канал ты у R1 ломаешь? До свитча или до интернета?

    До свича. Если ломать в интернет, то без трекинга нечего не поменяется. Должно все работать и так , нету смысла делать L3 ether-channel
  • Если ты сломаешь линк до R2 через единственный канал связи(Switch), то как R1 будет отсылать hsrp пакеты к R2?
  • Не как.
  • отредактировано Март 2016
    Поэтому и Init возникает, что у него нет соседа. Это как соседство bgp, только hsrp udp пакетами плюется. Создай независимый линк между роутерами и потестируй. Я что то об этом в начале не подумал. Должны состояния меняться вразумительно. Сейчас в своей лабе тоже откусил L2 линки, у меня оба active так и стояли) И в зависимости у кого включен tracking, просто сидит с пониженным приоритетом и не видит соседа)
    Помни, что HSRP объединяет роутерЫ в группу standby. Эффект работает только с двумя и более роутерами.
  • отредактировано Март 2016
    Не знаю как в реале, но я вот попробовал так, работает норм
    hsrp.jpg 74.7K
  • отредактировано Март 2016
    Anumrak написал:

    Поэтому и Init возникает, что у него нет соседа. Это как соседство bgp, только hsrp udp пакетами плюется. Создай независимый линк между роутерами и потестируй. Я что то об этом в начале не подумал. Должны состояния меняться вразумительно. Сейчас в своей лабе тоже откусил L2 линки, у меня оба active так и стояли) И в зависимости у кого включен tracking, просто сидит с пониженным приоритетом и не видит соседа)
    Помни, что HSRP объединяет роутерЫ в группу standby. Эффект работает только с двумя и более роутерами.

    Мне кажется ты не прав. Везде где описывается HSRP схема такая как у меня берется. Прямые линки не строят между роутерами.

    Вот из википедии
    По умолчанию, активный маршрутизатор, каждые 3 секунды, рассылает hello-сообщение, которое сообщает «Ребята всё ок! Я еще в строю!». Если в течение 10 секунд нет ни одного hello-сообщения от активного маршрутизатора, резервный считает, что активный маршрутизатор «упал» и берет на себя роль активного маршрутизатора. После того, как определился новый активный маршрутизатор, снова, начинаются выборы нового резервного маршрутизатора.
    Я так понимаю - когда у меня поднимается поломаный линк то мой роутер R1 должен стать стенд баем потому что проведутся выборы на звание резервного, при преемпе выключенном. А если преемп включен, то тогда перевыборы полные.
  • отредактировано Март 2016
    http://xgu.ru/wiki/HSRP_в_Cisco


    Первая топология похожа на твою, но там роутеры связаны четырьмя линками через 2 коммутатора.
  • Может я и не прав, но ты попробуй связать роутеры не клиентскими линками. Или у тебя есть теория каким образом еще будут передаваться hsrp пакеты каждые 3 hello 10 hold секунд?
  • Anumrak написал:

    Может я и не прав, но ты попробуй связать роутеры не клиентскими линками. Или у тебя есть теория каким образом еще будут передаваться hsrp пакеты каждые 3 hello 10 hold секунд?

    Такой теории у меня нету. Хелоу и холд пакеты нужны для того что бы показивать что сосед жив. Тебе нету смысла в пакете который будет говорить что сосед мертв потому что если пакет хелоу не пришел - это и значит что сосед умер. Понимаешь? После того как я оборвал связь между Р1 и свичем. пакеты хелоу перестали приходить к р2. и р2 стал активным. Потом я востановил линк. В сети появился роутер р1 с большим приоритетом. Он посылает свои хелоу пакеты р2 свои хелоу пакеты. В чем проблема? Обьясни мне, зачем тебе независимый линк между роутерами? Это ж бред
  • У меня то нет проблем, у меня выборка активного роутера происходит нормально. Я пытаюсь твою проблему разрешить.
    Дело в том, если не будет транспорта между роутерами, они оба будут активными. После того как ты оборвал линк, они оба стали активными, так? До этого R1 перешел в init state. Когда ты восстановил линк, R2 становится Standby, а R1 активным. Все так? R1 не становится Standby после разрыва?
  • Anumrak написал:

    У меня то нет проблем, у меня выборка активного роутера происходит нормально. Я пытаюсь твою проблему разрешить.
    Дело в том, если не будет транспорта между роутерами, они оба будут активными. После того как ты оборвал линк, они оба стали активными, так? До этого R1 перешел в init state. Когда ты восстановил линк, R2 становится Standby, а R1 активным. Все так? R1 не становится Standby после разрыва?

    Дружище. Читай внимательно мои посты. После обрыва р1 стал в состояние инит. р2 стал активом. После востановления р1 стал активом, р2 стендбай. Как р1 может продолжать быть активом если у него оборвалась связь на интервейсе где HSRP настроен)))
Войдите или Зарегистрируйтесь чтобы комментировать.