Привет, незнакомец!

Похоже, вы здесь новенький. Чтобы принять участие, нажмите одну из кнопок ниже!

UnetLAB нюансы с подключением устройств

отредактировано апреля 2016 Раздел: UnetLab
настроил интерфейсы роутеров ,подключил их друг к другу. Пинги не проходят - ругается.

Router(config-if)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

*Mar 29 15:27:03.520: ether_vencap:(1975)
.
*Mar 29 15:27:05.521: ether_vencap:(1975)
.
*Mar 29 15:27:07.520: ether_vencap:(1975)
.
*Mar 29 15:27:09.521: ether_vencap:(1975)
.
*Mar 29 15:27:11.521: ether_vencap:(1975)

Когда подключаю роутеры через свич - пинги проходят без проблем.
Кто-нибудь сталкивался ?
Тэги темы:

Комментарии

  • Может версия не очень? поновее? или просто другую
  • А как безопасно можно и з консоли сменить версию UnetLAB и не потерять конфигурации , которые уже там присутствуют.
    Хотя ставил 3-4дня назад,перед этим апдейтил пакет.
  • Я про версию роутера, видимо у вас какой-то старый, думаю проблема в нем, что нить посвежее поставьте
  • Касательно версии UNL:

    apt-get update
    apt-get -y install unetlab

    На момент последеняя версия 1.0.0-6.
    3-4 дня назад была эта же версия.

    Но в Вашем случае попробуйте действительно проверить с другой версией роутера. Например, L3-ADVENTERPRISEK9-M-15.4-2T.bin - такой проблемы не наблюдается. Какая у Вас версия?
  • kr1k1 написал:

    настроил интерфейсы роутеров ,подключил их друг к другу. Пинги не проходят - ругается.

    Router(config-if)#do ping 3.3.3.3
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

    *Mar 29 15:27:03.520: ether_vencap:(1975)
    .
    *Mar 29 15:27:05.521: ether_vencap:(1975)
    .
    *Mar 29 15:27:07.520: ether_vencap:(1975)
    .
    *Mar 29 15:27:09.521: ether_vencap:(1975)
    .
    *Mar 29 15:27:11.521: ether_vencap:(1975)

    Когда подключаю роутеры через свич - пинги проходят без проблем.
    Кто-нибудь сталкивался ?

    Nu vo pervih nujno bol'she infi
    1. na chem UNL - esxi, workstation?
    2. kakoi CPU, skol'ko RAM i td
    3. kakie images i kak chto nastroeno
    4. po vozmojnosti lab export
  • michaely ,
    1)esxi
    2)CPU много, рам тоже.
    3) L3-ADVENTERPRISEK9-M15.2-2.15Т.bin
    2 интерфейса связаны с помощью Network, находятся в одной сети, линки в апе.
    ARP-не приходит.
    4)Пока нет такой вохможности, если будет совсем плохо - сделаю.
    Попробую сменить IOU.
    Yernat ,DimQ
    Быть может угостите нормальным IOU, а то никак эти версии найти не могу...
    Спасибо за ответы и советы.
  • отредактировано марта 2016
    есть вот такие, но не переименованные еще. Какие из них точно работают?
    -rw-r--r-- 1 root root 126948440 Mar 15 10:47 i86bi_linux-adventerprisek9-m-15.2.3
    -rw-r--r-- 1 root root 93580556 Mar 15 10:47 i86bi_linux-adventerprisek9-ms
    -rw-r--r-- 1 root root 126948440 Mar 15 10:46 i86bi_linux-adventerprisek9-ms.152-2
    -rwxr-xr-x 1 root root 128881272 Mar 15 10:46 i86bi_linux-adventerprisek9-ms.152-2.15.T
    -rw-r--r-- 1 root root 44342708 Mar 15 10:46 i86bi_linux-ipbase-ms
    -rwxr-xr-x 1 root root 64332184 Mar 15 10:47 i86bi_linux_l2-ipbasek9-ms.jan24-2013-B
    -rw-r--r-- 1 root root 61923512 Mar 15 10:47 i86bi_linux_l2-ipbasek9-ms.jan24-2013-team_track
    -rw-r--r-- 1 root root 56711156 Mar 15 10:46 i86bi_linuxl2-upk9-ms
    -rw-r--r-- 1 root root 58515544 Mar 15 10:46 i86bi_linuxl2-upk9-ms15
    -rw-r--r-- 1 root root 58515544 Mar 15 10:46 i86bi_linux_l2-upk9-ms.june20_2012_golden_spike
    -rw-r--r-- 1 root root 48668664 Mar 15 10:46 i86bi_linux-p-ms.251012_golden_spike
    -rw-r--r-- 1 root root 48668664 Mar 15 10:46 i86bi_linux-p-ms.june20_2012_golden_spike
    -rw-r--r-- 1 root root 99422572 Mar 15 10:47 i86bi_linux-tpgen+adventerprisek9-m-12.4
    -rw-r--r-- 1 root root 50091604 Mar 15 10:46 i86bi_linux-tpgen+ipbase-ms.PAGENT.4.7.0
  • Вот такой поищи L3-ADVENTERPRISEK9-M-15.4-2T.bin
  • очень важно подключения делать при выключеных девайсах.
    и какои ЦПУ, Интел? АМД?
  • Интел
  • kr1k1 написал:

    Интел

    тогда проблем поидее быть не должно
  • Проблему нашел, проблема была
    michaely написал:

    очень важно подключения делать при выключеных девайсах.

    В этом и была проблема
    Спасибо, я все решил
  • kr1k1 написал:

    Проблему нашел, проблема была

    michaely написал:

    очень важно подключения делать при выключеных девайсах.

    В этом и была проблема
    Спасибо, я все решил
    Отлично!
  • Здравствуйте, похожая проблема, пакеты просто не проходят бридж(проверено вайршарком), между двумя dynamips 3725, менял mtu, копался в дебагах, ничего толкового не нашёл, обновлял UNL, танцевал с бубном. При этом 3725 с VXR7209 нормально стыкуется. I5-65XX, 8G RAM, 4G - виртуалке.VMware Workstation
    Кто-то стыкался с данными граблями?(разумеется подключал выключенные девайсы)

    И ещё - как правильно экспортить конфиг устройств, а точнее сохранить его при перезагрузке гостевой виртуалки с UNL? подойдёт грубый ответ в ввиде ссылки :smile:
    Спасибо
  • К сожалению, на моему не большому опыту работы с UNL. Иногда встречаются проблемы, которые решаются только сменой системы cisco.
  • Ясно, понятно, спасибо за скорый ответ. Просто выглядит будто проблема в бридже, а насчёт корректного экспорта, не знаете?
  • Aeris написал:

    Здравствуйте, похожая проблема, пакеты просто не проходят бридж(проверено вайршарком), между двумя dynamips 3725, менял mtu, копался в дебагах, ничего толкового не нашёл, обновлял UNL, танцевал с бубном. При этом 3725 с VXR7209 нормально стыкуется. I5-65XX, 8G RAM, 4G - виртуалке.VMware Workstation
    Кто-то стыкался с данными граблями?(разумеется подключал выключенные девайсы)

    И ещё - как правильно экспортить конфиг устройств, а точнее сохранить его при перезагрузке гостевой виртуалки с UNL? подойдёт грубый ответ в ввиде ссылки :smile:
    Спасибо

    Как делалось подключение? С выключеными нодами или нет? Если нет, то подключения всегда нужно делать при быключеных нодах.

    Насчет export -
  • От себя могу добавить, что часто сталкиваюсь с неработающим пингом после соединения устройств. Лечится банальной остановкой всех устройств и потом заново их включением. После этого всё сразу работает. Бывает долго возишься с лабой, вроде всё правильно, а не пингуется ничего. Вот когда вспоминаешь про этот косяк, всё сразу проясняется :)
  • Вообщем - спасибо за ответы, но остановка/запуск нод помогает только если после этого пропингать другую сторону, иначе - трафик по этому линку не ходит, арпы тоже, а как следствие не инсталлируется роут в GRT
  • Артур написал:

    От себя могу добавить, что часто сталкиваюсь с неработающим пингом после соединения устройств. Лечится банальной остановкой всех устройств и потом заново их включением. После этого всё сразу работает. Бывает долго возишься с лабой, вроде всё правильно, а не пингуется ничего. Вот когда вспоминаешь про этот косяк, всё сразу проясняется :)

    Очень важно все подключения делат когда ноды выклычены.

    Вот такой файлик сделали:

  • michaely написал:

    Артур написал:

    От себя могу добавить, что часто сталкиваюсь с неработающим пингом после соединения устройств. Лечится банальной остановкой всех устройств и потом заново их включением. После этого всё сразу работает. Бывает долго возишься с лабой, вроде всё правильно, а не пингуется ничего. Вот когда вспоминаешь про этот косяк, всё сразу проясняется :)

    Очень важно все подключения делать когда ноды выключены.

    Вот такой файлик сделали:

    Ну когда бывает даже с выключенными нодами всё соединяешь, то при старте ошибка создания сети выскакивает. 11я кажется и нода не стартует. Со второго или даже с 10го бывает всё нормально запускается.
  • Артур, это в какой версии UNL?
  • отредактировано мая 2016
    michaely написал:

    Артур, это в какой версии UNL?

    Да вот даже в последней UNetLab version: 1.0.0-10. До этого в UNetLab version: 1.0.0-8 тоже самое было.

    Вот часть лога старта с ошибкой:
    May 21 18:40:37 INFO: CWD is /opt/unetlab/tmp/1/c7ffeed8-7e14-4583-beab-6648bc1ff617/13
    May 21 18:40:37 INFO: starting /opt/unetlab/wrappers/iol_wrapper -T 1 -D 13 -t "SW3" -F /opt/unetlab/addons/iol/bin/L2-ADVENTERPRISEK9-M-15.2-IRON-20151103.bin -d 0 -e 4 -s 0 -- -n 1024 -q -m 256 -c startup-config > /opt/unetlab/tmp/1/c7ffeed8-7e14-4583-beab-6648bc1ff617/13/wrapper.txt 2>&1 &
    May 21 18:40:43 ERROR: echo 65535 > /sys/class/net/vnet1_3/bridge/group_fwd_mask 2>&1 --- Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:43
    May 21 18:40:43 May 21 18:40:43 ERROR: Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:43 May 21 18:40:43 ERROR: Failed to create network (11).
    May 21 18:40:46 ERROR: echo 65535 > /sys/class/net/vnet1_4/bridge/group_fwd_mask 2>&1 --- Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:46
    May 21 18:40:46 May 21 18:40:46 ERROR: Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:46 May 21 18:40:46 ERROR: Failed to create network (11).
    May 21 18:40:48 ERROR: echo 65535 > /sys/class/net/vnet1_5/bridge/group_fwd_mask 2>&1 --- Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:48
    May 21 18:40:48 May 21 18:40:48 ERROR: Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:48 May 21 18:40:48 ERROR: Failed to create network (11).
    May 21 18:40:49 ERROR: echo 65535 > /sys/class/net/vnet1_16/bridge/group_fwd_mask 2>&1 --- Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:49
    May 21 18:40:49 May 21 18:40:49 ERROR: Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:49 May 21 18:40:49 ERROR: Failed to create network (11).
    May 21 18:40:50 ERROR: echo 65535 > /sys/class/net/vnet1_19/bridge/group_fwd_mask 2>&1 --- Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:50
    May 21 18:40:50 May 21 18:40:50 ERROR: Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:50 May 21 18:40:50 ERROR: Failed to create network (11).
    May 21 18:40:52 ERROR: echo 65535 > /sys/class/net/vnet1_20/bridge/group_fwd_mask 2>&1 --- Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:52
    May 21 18:40:52 May 21 18:40:52 ERROR: Failed to set group_fwd_mask on bridge (80028).
    May 21 18:40:52 May 21 18:40:52 ERROR: Failed to create network (11).
    May 21 18:40:54 INFO: tunctl -u unl1 -g root -t vunl1_11_0 2>&1
    May 21 18:40:54 INFO: tunctl -u unl1 -g root -t vunl1_11_16 2>&1
    May 21 18:40:54 INFO: tunctl -u unl1 -g root -t vunl1_11_32 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_48 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_1 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_17 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_33 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_49 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_2 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_18 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_34 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_50 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_3 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_19 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_35 2>&1
    May 21 18:40:55 INFO: tunctl -u unl1 -g root -t vunl1_11_51 2>&1

    Как я уже говорил, после нескольких попыток старта ноды, она всё таки запускается и всё нормально работает. Не особо критично, но оно бывает.
  • Артур, новый лаб, старый? дай больше инфы
  • michaely написал:

    Артур, новый лаб, старый? дай больше инфы

    Чаще сталкиваюсь с тем, что новую лабу завожу. Могу прислать всё что нужно, когда в следующий раз лабу заведу и ошибки будут. Скажите что нужно.
Войдите или Зарегистрируйтесь чтобы комментировать.