Привет, незнакомец!

Похоже, вы здесь новенький. Чтобы принять участие, нажмите одну из кнопок ниже!

QoS для Interface Vlan

отредактировано июля 2016 Раздел: Policing shaping
Здравствуйте коллеги!

Встала задача ограничить скорость клиенту до 20 Мбит/с. Его IP заведён на центральном коммутаторе Cisco 3750 как Interface VLAN и на него повешен IP. Можете помочь с примером ограничения скорости на интерфейс влане? Есть какие то конфиги готовые или чёткий пример как это сделать?

Схему как подклюён клиент прилагаю

Комментарии

  • отредактировано июля 2016
    Самый простой способ это порезать его трафик на этом интерфейсе:
    policy-map SPEED
    class class-default
    bandwidth percent 20
    Если гигабитный интерфейс, это соответственно 2% от максимальной скорости.
    Но тема QoS(L3) и CoS(L2) огромна. Советую тебе зайти на ютуб и посмотреть хороший вебинар на эту тему ;)
  • NAT_GTX написал:
    Большое спасибо за весьма интересную статью. Но увы, наша блин 3750 при применении service-policy на interface vlan шлёт лесом и пишет:

    c3750g(config-if)#service-policy output UPLOAD-20Mbit
    police command is not supported for this interface
    The interface does not support the specified policy configuration and/or parameter values.

    c3750g(config-if)#service-policy input DOWNLOAD-20Mbit
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.



    Так что видимо это осуществимо на роутерах, а L3 коммутаторам требуется несколько другая реализация :/
  • Артур написал:


    Так что видимо это осуществимо на роутерах, а L3 коммутаторам требуется несколько другая реализация :/

    Это не то слово, особенно на enterprise свичах, Cisco их сильно режет по функционалу, хотя ASIC явно умеет гораздо больше, чем задействовано в софте. Убогие D-Link делают эти свичи как стоячие.
    Другое дело, когда берешь ME серию коммутаторов Cisco.

    Вообще, QoS очень аппаратно зависим и надо очень внимательно читать документацию по настройке QoS именно для вашей железки.
  • gs1571 написал:

    Артур написал:


    Вообще, QoS очень аппаратно зависим и надо очень внимательно читать документацию по настройке QoS именно для вашей железки.

    Да я уже в этом убедился. Что там весьма специфичные настройки и требуется полное понимание как QoS в целом, так и конкретно по моей железке.
  • Артур написал:

    gs1571 написал:

    Артур написал:


    Вообще, QoS очень аппаратно зависим и надо очень внимательно читать документацию по настройке QoS именно для вашей железки.

    Да я уже в этом убедился. Что там весьма специфичные настройки и требуется полное понимание как QoS в целом, так и конкретно по моей железке.
    Главное даже не в этом. Там принципиально может не быть нужной вам функциональности, хотя бы потому, что Cisco не считает эту функциональность необходимой для Enterprise сетей.
  • отредактировано июля 2016
    Вот пример как зарезать по влану, на 10 мегабит, но у вас там IP адрес :)
    Просто пускай это будет здесь.

    mac access-list extended customerXXX
    permit any any vlan 100

    vlan 100
    name customerXXX

    class-map match-all customerXXX
    match access-group name customerXXX

    policy-map customerXXX
    class customerXXX
    police 10000000 conform-action transmit exceed-action drop

    interface Vlan100
    no ip address
    mac packet-classify
    service-policy input customerXXX
    service-policy output customerXXX
  • NAT_GTX написал:

    Попробуйте зарезать по влану, пример на 10 мегабит:

    mac access-list extended customerXXX
    permit any any vlan 100

    vlan 100
    name customerXXX

    class-map match-all customerXXX
    match access-group name customerXXX

    policy-map customerXXX
    class customerXXX
    police 10000000 conform-action transmit exceed-action drop

    interface Vlan100
    ip address x.x.x.x x.x.x.x
    mac packet-classify
    service-policy input customerXXX
    service-policy output customerXXX

    Спасибо, обязательно попробую ;) Отпишусь по результатам.
  • отредактировано июля 2016
    Артур написал:

    NAT_GTX написал:
    Большое спасибо за весьма интересную статью. Но увы, наша блин 3750 при применении service-policy на interface vlan шлёт лесом и пишет:

    c3750g(config-if)#service-policy output UPLOAD-20Mbit
    police command is not supported for this interface
    The interface does not support the specified policy configuration and/or parameter values.

    c3750g(config-if)#service-policy input DOWNLOAD-20Mbit
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.
    %QoS: policy-map with police action at parent level not supported on Vlan500 interface.



    Так что видимо это осуществимо на роутерах, а L3 коммутаторам требуется несколько другая реализация :/
    Вы полисинг вешайте не на интерфейс влан, а на физически интерфейс смотрящий в сторону клиента.
  • отредактировано июля 2016
    Вот ещё пример:

    class-map match-all customerXXX
    match access-group name customerXXX

    policy-map customerXXX
    class customerXXX
    police 16000000 1000000 exceed-action drop

    interface GigabitEthernet0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk allowed vlan ...
    service-policy input customerXXX
    service-policy output customerXXX

    ip access-list extended customerXXX
    permit ip any host 192.168.0.1
    permit ip host 192.168.0.1 any
Войдите или Зарегистрируйтесь чтобы комментировать.