Привет, незнакомец!

Похоже, вы здесь новенький. Чтобы принять участие, нажмите одну из кнопок ниже!

UNL STP проблема (лабораторная 15).

Раздел: UnetLab
Загрузив отсюда (http://ccie.linkmeup.ru/2016/05/13/laboratornaya-rabota-po-teme-15-routing-protocol-features/) конфигурацию, начинается какое-то мракобесие с STP. Предлагаю обсудить проблему и выяснить наконец, как это победить.
Мой комментарий оттуда: "Я никак не могу STP победить. Может у меня одного такая проблема: постоянно на свиче во всех вланах протухает информация о корне STP, вследствие чего ALT BLK порт переходит в FWD и генерируется TC. Из-за этого все транковые порты, в том числе и на маршрутизаторы постоянно флапают между BLK, LRN, FWD состояниями. И да, 10й пункт из-за этого не проходит. Я уже два дня бьюсь с этой проблемой. И пробовал max-age задирать в pvst+ и даже VTP домен с пранингом настроил на свичах, чтобы уменьшить число вланов в транках и всё равно такая фигня. Я не пойму, толи это косяк образа, толи лыжи не едут, толи сам… Образ использую тот, что и все. Ранее такая проблема в предыдущих лабах не возникала. Весь мозг себе сломал уже об этот STP."
Судя по другим комментам проблема не разовая. Помогите, пожалуйста, или скажите хотя бы, что у меня руки кривые и я что-то не так указал. Хотя достаточно только загрузить начальную конфигурацию и ждать, проблема проявится в скором времени.

Комментарии

  • аналогично
    первый раз такое замечено на quad core q95** 8 G RAM, baremetal UNL

    итак, проверено на vmvare workstation 12 pro i7 3770 8G RAM. Сначала запущены свичи с конфигом, полет нормальный. далее добавляются роутеры по одному. \n В итоге, имею рабочую лабу. жду 15 минут, в варежке root+tc не наблюдаю. Экспортим конфиг, ставил его как start-up. Останавливаем все ноды. Запускаем все ноды, ждем. Через несколько минут SW1 какает в консоль
    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 82088 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "Spanning Tree", ipl= 0, pid= 119
    -Traceback= A1EDCB5z BB05043z BAFC645z C5F785Ez 89657CEz 8966119z 89624F1z 9190DD5z 9190A50z 9190759z 91905E3z B981527z B980218z

    SW1#
    %SW_VLAN-3-VLAN_PM_NOTIFICATION_FAILURE: VLAN Manager synchronization failure with Port Manager over port stp forwarding change (3)
    -Traceback= A1EDCB5z 933FA2Dz 92934DFz 925E503z 92D4D04z

    SW1#
    %SW_VLAN-3-VLAN_PM_NOTIFICATION_FAILURE: VLAN Manager synchronization failure with Port Manager over port stp forwarding change (3)
    -Traceback= A1EDCB5z 933FA2Dz 92934DFz 925E503z 92D4D04z

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 83616 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "Pool Manager", ipl= 6, pid= 5
    -Traceback= A1EDCB5z BB05043z BAFC645z C5F785Ez 89657CEz BB1E460z BB1DE90z

    SW1#
    %SW_VLAN-3-VLAN_PM_NOTIFICATION_FAILURE: VLAN Manager synchronization failure with Port Manager over port stp forwarding change (3)
    -Traceback= A1EDCB5z 933FA2Dz 92934DFz 925E503z 92D4D04z

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 83616 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "Pool Manager", ipl= 6, pid= 5
    -Traceback= A1EDCB5z BB05043z BAFC645z C5F785Ez 89657CEz BB1E460z BB1DE90z

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 83576 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "Pool Manager", ipl= 6, pid= 5
    -Traceback= A1EDCB5z BB05043z BAFC645z C5F785Ez 89657CEz BB1E460z BB1DE90z

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 83576 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "Pool Manager", ipl= 6, pid= 5
    -Traceback= A1EDCB5z BB05043z BAFC645z C5F785Ez 89657CEz BB1E460z BB1DE90z

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 83760 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "Pool Manager", ipl= 6, pid= 5
    -Traceback= A1EDCB5z BB05043z BAFC645z C5F785Ez 89657CEz BB1E460z BB1DE90z

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 83616 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "*Sched*", ipl= 4
    -Traceback= 0z F7720938z 1z

    Еще через несколько минут каждый свич считает себя рутом во всех влан, пропадают маршруты из РТ. Лаба перестает быть работоспособной.

  • попробуйте больше RAMa дать IOU нодам
  • давал 512 против 256, не дало результата
    сейчас задал 1024, подожду полчасика, пока деревья построились
  • ...и все по новому

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 392960 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "*Sched*", ipl= 4
    -Traceback= 0z F77C9938z 1z

    SW1#
    %SYS-2-MALLOCFAIL: Memory allocation of 1180 bytes failed from 0x89657CE, alignment 8
    Pool: Processor Free: 392960 Cause: Memory fragmentation
    Alternate Pool: None Free: 0 Cause: No Alternate pool
    -Process= "Pool Manager", ipl= 6, pid= 5
    -Traceback= A1EDCB5z BB05043z BAFC645z C5F785Ez 89657CEz BB1E460z BB1DE90z
    SW1#
  • Да, я память тоже наваливал на все ноды. Результат тот же.
  • # show vtp status
    Какой режим и какая версия?
  • Transparent везде. Пробовал настраивал VTPv2 с сервером на SW1 и клиентами на остальных свичах. Одно и то же.
  • При переводе свичей в mode pvst проблема исчезает.
  • Это понятно, что проблема исчезает в другом режиме. Почему RSTP не хочет нормально работать?
  • отредактировано мая 2016
    Проблема явно не в образах. Пытался воспроизвести проблему. На нескольких различных ноутбуках все работает. На отдельном сервере - тоже. Образ предоставленный использовал. Ставлю на аппаратные ресурсы, на которых запускается UNL. Может на взаимодействие UNL с конкретным железом. Но, повторюсь, на i5 и i3 и по 256 на каждом свиче - все отрабатывает штатно
  • Интересно, то 15 лаб прошло нормально, а на 16 вдруг началось.
Войдите или Зарегистрируйтесь чтобы комментировать.